<i id='ysphy'></i>

  • <acronym id='ysphy'><em id='ysphy'></em><td id='ysphy'><div id='ysphy'></div></td></acronym><address id='ysphy'><big id='ysphy'><big id='ysphy'></big><legend id='ysphy'></legend></big></address>

        1. <tr id='ysphy'><strong id='ysphy'></strong><small id='ysphy'></small><button id='ysphy'></button><li id='ysphy'><noscript id='ysphy'><big id='ysphy'></big><dt id='ysphy'></dt></noscript></li></tr><ol id='ysphy'><table id='ysphy'><blockquote id='ysphy'><tbody id='ysphy'></tbody></blockquote></table></ol><u id='ysphy'></u><kbd id='ysphy'><kbd id='ysphy'></kbd></kbd>
        2. <ins id='ysphy'></ins>

          <dl id='ysphy'></dl>
          <i id='ysphy'><div id='ysphy'><ins id='ysphy'></ins></div></i>

        3. <fieldset id='ysphy'></fieldset>

            <span id='ysphy'></span>

            <code id='ysphy'><strong id='ysphy'></strong></code>

            在各种Linux发行版上安装Git的教程

            • 时间:
            • 浏览:8
            • 来源:124软件资讯网

                Git是一个盛行的开源版本控制系统(VCS)  ,最初是为Linux情况开发的  。跟CVS或者SVN这些版本控制系统差别的是 ,Git的版本控制被以为是“漫衍式的”  ,某种意义上  ,git的当地事情目录可以作为一个功效完善的堆栈来使用  ,它具备完整的历史记载和版本追踪能力  。在这种事情模子之下  ,各个协作者将内容提交到他们的当地堆栈中(与之相对的会总是提交到焦点堆栈) ,若是有须要  ,再有选择性地推送到焦点堆栈 。这就为Git这个版本治理系统带来了大型协作系统所必须的可扩展能力和冗余能力  。

                使用保证理器安装Git

                Git已经被所有的主流Linux刊行版所支持  。以是安装它最简朴的要领就是使用各个Linux刊行版的保证理器 。

                Debian, Ubuntu, 或 Linux Mint

                代码如下:

                $ sudo apt-get install git

                Fedora, CentOS 或 RHEL

                代码如下:

                $ sudo yum install git

                或

                代码如下:

                $ sudo dnf install git

                Arch Linux

                代码如下:

                $ sudo pacman -S git

                OpenSUSE

                代码如下:

                $ sudo zypper install git

                Gentoo

                代码如下:

                $ emerge --ask --verbose dev-vcs/git

                从源码安装Git

                若是由于某些缘故原由  ,你希望从源码安装Git  ,根据如下先容操作  。

                安装依赖包

                在构建Git之前  ,先安装它的依赖包  。

                Debian, Ubuntu 或 Linux Mint

                代码如下:

                $ sudo apt-get install libcurl4-gnutls-dev libexpat1-dev gettext libz-dev libssl-dev asciidoc xmlto docbook2x

                Fedora, CentOS 或 RHEL

                代码如下:

                $ sudo yum install curl-devel expat-devel gettext-devel openssl-devel zlib-devel asciidoc xmlto docbook2x

                从源码编译Git

                从 https://github.com/git/git/releases 下载最新版本的Git  。然后在/usr下构建和安装  。

                注重  ,若是你计划安装到其他目录下(例如:/opt)  ,那就把"--prefix=/usr"这个设置下令使用其他路径替换掉  。

                代码如下:

                $ cd git-x.x.x

                $ make configure

                $ ./configure --prefix=/usr

                $ make all doc info

                $ sudo make install install-doc install-html install-info