<fieldset id='gzqiq'></fieldset>
  1. <ins id='gzqiq'></ins>
    <span id='gzqiq'></span>

    <i id='gzqiq'></i>

    <dl id='gzqiq'></dl>
  2. <tr id='gzqiq'><strong id='gzqiq'></strong><small id='gzqiq'></small><button id='gzqiq'></button><li id='gzqiq'><noscript id='gzqiq'><big id='gzqiq'></big><dt id='gzqiq'></dt></noscript></li></tr><ol id='gzqiq'><table id='gzqiq'><blockquote id='gzqiq'><tbody id='gzqiq'></tbody></blockquote></table></ol><u id='gzqiq'></u><kbd id='gzqiq'><kbd id='gzqiq'></kbd></kbd>

    1. <acronym id='gzqiq'><em id='gzqiq'></em><td id='gzqiq'><div id='gzqiq'></div></td></acronym><address id='gzqiq'><big id='gzqiq'><big id='gzqiq'></big><legend id='gzqiq'></legend></big></address><i id='gzqiq'><div id='gzqiq'><ins id='gzqiq'></ins></div></i>

        <code id='gzqiq'><strong id='gzqiq'></strong></code>

          博时第三产业基金净值Ubuntu6.06 Linux安装Mplayer过程解析

          • 时间:
          • 浏览:1
          • 来源:124软件资讯网
            魅力研习社43.

            sudo apt博时第三产业基金净值-get install mplayer-386

            sudo apt-get install mplayer-fonts

            sudo apt-get install mozilla-mplayer

            sudo 五月花djcp /etc/mplayer/mplayer.conf /etc/mplayer/mplayer.conf_backup

            sudo gedit /etc/mplayer/mplayer.conf


            找出下面这一行

            ... vo=x11, # To specify default video driver (see -vo help for...


            以下面这一行取代

            vo=xv, # To specify default video driver (see -vo help for


            安装 w32codecs解码器(用于播放wmv、rmvb等常见windows平台下的多媒体文件;假设你已经添加了ubuntu-cn源 。

            $ sudo apt-get install w32codecs


            设置中文字幕显示(可选)

            cd ; mkdir .mplayerln -sf /usr/share/fonts/truetype/arphic/uming.ttf .mplayer/subfont.ttfgedit .mplayer/gui.config

            sub_cp = "GBK"font_text_scale = "4.旅易网000000"font_osd_scale = "4.000000"sub_fuzziness=2


            设置设置文件

            gedit .mplayer/config


            subcp=cp936


            本以为用上面的要领就可以轻松搞定了,惋惜网络不行,没下来,只好自己编译了  。

            1、下载相关codes(http://www.mplayerhq.hu/MPlayer/)主要都在这里

            Mplayer-1.0rc1.tar.bz2(主法式)

            Abyss-1.6.tar.bz2 (皮肤)

            all-20061022.tar.bz2

            windows-all-20061022.zip(建议不要在win下使用. rar,用. zip)


            2、安装历程

            a.安装响应的解码

            sudo mkdir /usr/lib/codecs

            sudo mkdir /usr/lib/wincodecs

            tar jxvf all-20061022.tar.bz2

            sudo mv all-20060611/* /usr/lib/codecs

            unzip windows-all-20061022.zip

            sudo mv windows-all-20060611/* /usr/lib/wincodecs

            b.安装mplayer

            tar jxvf MPlayer-1.0rc1.tar.bz2

            cd MPlayer-1.0rc1

            ./configure --prefix=/usr/local/mplayer --enable-gui --enable-freetype --with-codecsdir=/usr/lib/codecs/ --with-win32libdir=/usr/lib/wincodecs/ --language=zh_CN

            注重:

            --prefix=/usr/local/mplayer 是安装路径

            --enable-gui 安装图形化用户界面

            --enable-freetype 调治字体(可以防止Mplayer发生乱码)

            --with-codecsdir=/usr/lib/codecs/

            --with-win32libdir=/usr/lib/wincodecs 指定解码位置

            --language=zh_CN 中文


            堕落:

            Checking for inttypes.h (required) ... no

            Checking for bitypes.h (inttypes.h predecessor) ...no

            Error: Cannot find header either inttypes.h or bitypes.h (see DOCS/HTML/en/faq.h)

            郁闷,预计又是什么开发库没有装,没措施google了下,看到网上有人说得装libc6-dev,装一个吧:

            sudo apt-get install libc6-dev

            运行历程中安装了两个包:libc6-dev linux-kernel-headers


            再次运行configure,又堕落了:

            Checking for GUI ... yes

            Error: The GUI requires PNG support, please install libpng and libpng-dev packages.

            Check "configure.log" if you do not understand why it failed.

            我哭,这个也没有啊,dpkg了下,系统内里是有libpng的,可是没有libpng-dev,接着get吧:

            sudo apt-get install libpng12-dev


            运行configure,再次堕落,瓦解了.....

            Error: X11 support required for GUI compilation.

            去网上Google了下,需要GTK的dev包,继续get,我就不信了:

            sudo apt-get install libgtk1.2-dev

            这会安装了15个包:

            libglib1.2 libglib1.2-dev libgtk1.2 libgtk1.2-common libgtk1.2-dev libx11-dev libxau-dev libxdmcp-dev libxext-dev libxi-dev pkg-config x11proto-core-dev x11proto-input-dev x11proto-kb-dev x11proto-xext-dev

            无语了......还好终与configure过了.


            接着make吧,又一次华美的倒在了错误之下:

            ./version.sh `cc -dumpversion`

            cc -c -Wdeclaration-after-statement -fno-PIC -O4 -march=prescott -mtune=prescott -pipe -ffast-math -fomit-frame-pointer -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I. -I./libavutil -I./libavcodec -o mplayer.o mplayer.c

            In file included from mplayer.c:59:

            libvo/font_load.h:5:22: error: ft2build.h: No such file or directory

            libvo/font_load.h:6:10: error: #include expects "FILENAME" or

            In file included from mplayer.c:59:

            libvo/font_load.h:40: error: expected specifier-qualifier-list before 'FT_Face'

            make: *** [mplayer.o] 错误 1

            实在在编译时加入--enable-freetype参数是为相识决字幕乱码的问题 ,可是加了之后make时堕落.不加--enable-freetype是可以正常编译  ,不外GUI和字幕均为乱码.讨教了N小我私家,最后得知,问题是由于当初安装编译情况的时间选择的是GTK1.2 ,更新为2.0既可顺遂编译:

            sudo apt-get install libgtk2.0-dev

            make一下,种种warning,看得我都眼花,还好最后通过了,最后

            sudo make install


            c.安装皮肤

            tar jxvf Abyss-1.6.tar.bz2

            sudo mv Abyss /usr/local/mplayer/share/mplayer/skins/

            cd /usr/local/mplayer/share/mplayer/skins/

            sudo mv Abyss default


            d.设置字体

            小我私家比力喜欢幼园,以是复制个simyou.ttf过来,copy到~/.mplayer下面,更名成subfont.ttf

            编辑下~/.mplayer下面的gui.conf:

            sub_cp = “cp936″

            font_factor = “0.750000″

            font_encoding = "Unicode"


            若是另有问题  ,请试着修改gui.conf文件中的sub_cp = “cp936″,把cp936换成其他的例如GB,GBK,GB2312,GB18030等等 ,总有一个行的 。至于中文字幕就再说吧,没有看字幕的习惯,


            终于算是装上了,执行法式在/usr/local/mplayer/bin中,在桌面建个起动器,激动的时刻到来了,加入了一首歌Maria,居然没声!!!!!报错:

            [AO OSS] audio_setup: Can't open audio device /dev/dsp: Device or resource busy

            ao_nas: init(): Can't open nas audio server -> nosound

            再次郁闷,仔细检查了下,Ubuntu的桌面情况使用的是Gnome  ,默认使用是esd (Enlightenment Sound Daemon)  ,而不是我们通常使用的ALSA或者更老的OSS  。esd的功效就是卖力Gnome的配景音效  ,而且它有多音源同时发声的能力 。自己安装的mplayer默认是使用OSS  ,导致在X下会提醒"/dev/dsp被占用"之类的错误信息而不能正常使用  ,/dev/dsp就是被esd所占用了 。

            把ESD关了:System > Preferences > Sound Preferences 中反选 Enable sound server startup 和 Sounds for events,效果就一切都正常了,就是Gnome的配景音效不见了